Please do not upgrade your Mac OS to the latest version (10.14 Mojave or 10.15 Catalina) as this is not currently supported. We are working to resolve this issue
The Remote Desktop supports modern secure vendor supported and updated operating systems and browsers only, requiring TLS encryption 1.2
Desktop
How to Setup Remote Desktop
Helpdesk
Password Manager